const regex = /(?<=^.{68,69}\S+)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^.{68,69}\\S+)\\s', 'gm')
const str = `hello i am a very long string that needs to be split into two differe parts! thank you so much for helping
hello i am a very long string that needs to be split into two different parts! thank you so much for helping`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}