import re
regex = re.compile(r"(?<=^.{68,69}\S+)\s", flags=re.MULTILINE)
test_str = ("hello i am a very long string that needs to be split into two differe parts! thank you so much for helping\n\n"
"hello i am a very long string that needs to be split into two different parts! thank you so much for helping")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")