import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d{4} )\\w+";
final String string = "1966 Ford Fairlane 1966 Ford Falcon 1966 Ford Ranchero 1966 Mercury Caliente 1966 Mercury Comet 1966 Mercury Cyclone 1966 Mercury Villager";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}