$re = '/(?<=\d{4} )\w+/m';
$str = '1966 Ford Fairlane 1966 Ford Falcon 1966 Ford Ranchero 1966 Mercury Caliente 1966 Mercury Comet 1966 Mercury Cyclone 1966 Mercury Villager';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);