import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*class\\s+\n"
+ "(?P<class>\\S+)[^\\{\\}]+(\\{\n"
+ "(?:[^\\{\\}]*|(?2))*\n"
+ "\\})";
final String string = "\n"
+ "<?php\n\n"
+ "// base class with member properties and methods\n"
+ "class Vegetable {\n\n"
+ " var $edible;\n"
+ " var $color;\n\n"
+ " function Vegetable($edible, $color=\"green\")\n"
+ " {\n"
+ " $this->edible = $edible;\n"
+ " $this->color = $color;\n"
+ " }\n\n"
+ " function is_edible()\n"
+ " {\n"
+ " return $this->edible;\n"
+ " }\n\n"
+ " function what_color()\n"
+ " {\n"
+ " return $this->color;\n"
+ " }\n\n"
+ "} // end of class Vegetable\n\n"
+ "// extends the base class\n"
+ "class Spinach extends Vegetable {\n\n"
+ " var $cooked = false;\n\n"
+ " function __construct()\n"
+ " {\n"
+ " parent::__construct(true, \"green\");\n"
+ " }\n\n"
+ " function cook_it()\n"
+ " {\n"
+ " $this->cooked = true;\n"
+ " }\n\n"
+ " function is_cooked()\n"
+ " {\n"
+ " return $this->cooked;\n"
+ " }\n\n"
+ "} // end of class Spinach\n\n"
+ "?>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}