import re
regex = re.compile(r"""
^\s*class\s+
(?P<class>\S+)[^{}]+(\{
(?:[^{}]*|(?2))*
\})
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("\n"
"<?php\n\n"
"// base class with member properties and methods\n"
"class Vegetable {\n\n"
" var $edible;\n"
" var $color;\n\n"
" function Vegetable($edible, $color=\"green\")\n"
" {\n"
" $this->edible = $edible;\n"
" $this->color = $color;\n"
" }\n\n"
" function is_edible()\n"
" {\n"
" return $this->edible;\n"
" }\n\n"
" function what_color()\n"
" {\n"
" return $this->color;\n"
" }\n\n"
"} // end of class Vegetable\n\n"
"// extends the base class\n"
"class Spinach extends Vegetable {\n\n"
" var $cooked = false;\n\n"
" function __construct()\n"
" {\n"
" parent::__construct(true, \"green\");\n"
" }\n\n"
" function cook_it()\n"
" {\n"
" $this->cooked = true;\n"
" }\n\n"
" function is_cooked()\n"
" {\n"
" return $this->cooked;\n"
" }\n\n"
"} // end of class Spinach\n\n"
"?>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")