$re = '/(?:STRING.*?|\G(?<=.).*?)\K\)/m';
$str = 'foo)
STRING) more text ) more text )
foo) STRING)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);