re = /(?:STRING.*?|\G(?<=.).*?)\K\)/m
str = 'foo)
STRING) more text ) more text )
foo) STRING)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end