package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]*( [A-Za-z]+)*$`)
var str = `regular expression for only one space between the words in a sentence`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}