$re = '/^[A-Za-z]*( [A-Za-z]+)*$/m';
$str = 'regular expression for only one space between the words in a sentence';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);