using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%s(?!\[)(?::\d+)?";
string input = @"%sprix is the %s[4] online %s[3]:6 pshopping %s:9 in %s";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}