$re = '/%s(?!\[)(?::\d+)?/';
$str = '%sprix is the %s[4] online %s[3]:6 pshopping %s:9 in %s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);