# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B(?:(?=(?:\d{3})+\.)|(?!.*\.)(?<!\..*)(?=(?:\d{3})+$))/,/gm;t' <<< "1234
1234.5678
1234567
1234567.89012
123"