const regex = /\B(?:(?=(?:\d{3})+\.)|(?!.*\.)(?<!\..*)(?=(?:\d{3})+$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B(?:(?=(?:\\d{3})+\\.)|(?!.*\\.)(?<!\\..*)(?=(?:\\d{3})+$))', 'gm')
const str = `1234
1234.5678
1234567
1234567.89012
123`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);