re = /\((.*?)\)/m
str = 'Голос [сказал](glagol :: edinstvennii :: no_role :: no_group) , что он новый вид [жизни](sushestvitelnoe :: edinstvennii :: no_role :: no_group)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end