#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#\*([\s\S]*?)#@"
Local $sString = "#*OQL[C++]: Extending C++ with an Object Query Capability" & @CRLF & _
"#@José A. Blakeley" & @CRLF & _
"#t1995" & @CRLF & _
"#cModern Database Systems" & @CRLF & _
"#index0" & @CRLF & _
"#*Transaction Management in Multidatabase Systems" & @CRLF & _
"#@Yuri Breitbart,Hector Garcia-Molina,Abraham Silberschatz" & @CRLF & _
"#t1995" & @CRLF & _
"#cModern Database Systems" & @CRLF & _
"#index1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")