re = /#\*([\s\S]*?)#@/
str = '#*OQL[C++]: Extending C++ with an Object Query Capability
#@José A. Blakeley
#t1995
#cModern Database Systems
#index0
#*Transaction Management in Multidatabase Systems
#@Yuri Breitbart,Hector Garcia-Molina,Abraham Silberschatz
#t1995
#cModern Database Systems
#index1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end