const regex = /[A-Za-z]+\s+\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z]+\\s+\\\/', 'gm')
const str = `Material TD Vandal High Supreme Signal Blue / University Red-B`;
const subst = `- $0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);