re = /[A-Za-z]+\s+\//m
str = 'Material TD Vandal High Supreme Signal Blue / University Red-B'
subst = '- $0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result