# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w+) +\w+ +(?:\[[^\]]+\] *)?"
test_str = ("0000 10 Text(\"TOTAL,SOME RANDOM TEXT\") (1122aabb)\n"
"0010 5 D==1122aabb (1122aabb)\n"
"0015 17 Text(\"AND,SOME,MORE\") (00000001)\n"
"002c 5 D==1 (1)\n"
"0031 1 !D (ccdd3344)\n"
"0032 5 D==ccdd3344 (ccdd3344)\n"
"0037 2 !1 (1)\n"
"0039 0 [AAAA] Fff\n"
"0039 1 [BBBB] Aaa\n"
"003a 6 N(05, eeff5566) (eeff5566)\n"
"0040 1 Qq\n"
"0041 2 $ab ([String]:\"Unknown\")\n"
"0043 f Call A/SomeFunc-X\n"
"0052 1 cd")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.