// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+) +\w+ +(?:\[[^\]]+\] *)?").unwrap();
let string = "0000 10 Text(\"TOTAL,SOME RANDOM TEXT\") (1122aabb)
0010 5 D==1122aabb (1122aabb)
0015 17 Text(\"AND,SOME,MORE\") (00000001)
002c 5 D==1 (1)
0031 1 !D (ccdd3344)
0032 5 D==ccdd3344 (ccdd3344)
0037 2 !1 (1)
0039 0 [AAAA] Fff
0039 1 [BBBB] Aaa
003a 6 N(05, eeff5566) (eeff5566)
0040 1 Qq
0041 2 $ab ([String]:\"Unknown\")
0043 f Call A/SomeFunc-X
0052 1 cd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}