using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z0-9_:-]+(?:[.*][a-z0-9_:-]+)+";
string input = @"this does not work libname.data
libname.data
libname.data;
libname.data(stuff)
libname.data(stuff);
libname.data (stuff)
libname.data(stuff);
libname.*
a.b.c";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}