import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z0-9_:-]+(?:[.*][a-z0-9_:-]+)+";
final String string = "this does not work libname.data\n"
+ "libname.data\n"
+ "libname.data;\n"
+ "libname.data(stuff)\n"
+ "libname.data(stuff);\n"
+ "libname.data (stuff)\n"
+ "libname.data(stuff);\n"
+ "libname.*\n"
+ "a.b.c";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}