$re = '/[a-zA-Z]\w+\'?\w*/m';
$str = 'Random01\'example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);