const regex = /[A-Z] ?\..+?(?=$|[A-Z] ?\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z] ?\\..+?(?=$|[A-Z] ?\\.)', 'gm')
const str = `A. lorem ipsum dolor sit B . 41dipiscing elit sedC. lorem ipsum dolor sit amet D. 35 Consectetur adipiscing E .Sed do eiusmod tempor`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}