re = /[A-Z] ?\..+?(?=$|[A-Z] ?\.)/m
str = 'A. lorem ipsum dolor sit B . 41dipiscing elit sedC. lorem ipsum dolor sit amet D. 35 Consectetur adipiscing E .Sed do eiusmod tempor'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end