using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""|\] )[\w ]+(?=""| \[)";
string input = @"Hello ""Counts1 [ignore1] Counts2 [ignore2] Counts3 [ignore3] Count these too""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}