re = /(?<="|\] )[\w ]+(?="| \[)/
str = 'Hello "Counts1 [ignore1] Counts2 [ignore2] Counts3 [ignore3] Count these too"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end