#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=\n|\A)start of line"
Local $sString = "this is not at the start of line" & @CRLF & _
"" & @CRLF & _
"but this is:" & @CRLF & _
"start of line" & @CRLF & _
"something else"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")