re = /(?<=\n|\A)start of line/
str = 'this is not at the start of line
but this is:
start of line
something else'
# Print the match result
str.match(re) do |match|
puts match.to_s
end