package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?[\d-\s()]{4,20}$`)
var str = `+79221761932
89221761932
8(922)1761932
8 922 176 19 32
8 (922) 176 19 32
+7 (922) 176 19 32
+7 (922) 176-19-32
8 800 12345678
9221761932`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}