const regex = /^\+?[\d-\s()]{4,20}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?[\\d-\\s()]{4,20}$', 'gm')
const str = `+79221761932
89221761932
8(922)1761932
8 922 176 19 32
8 (922) 176 19 32
+7 (922) 176 19 32
+7 (922) 176-19-32
8 800 12345678
9221761932`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}