$re = '/(?<name>\w+)=(?<value>.+?)(?=[,\]])(?#The following text makes sure that the match isn\'t inside quotes, #found_on_internet )(?=([^"\\\\]*(\\\\.|"([^"\\\\]*\\\\.)*[^"\\\\]*"))*[^"]*$)/';
$str = 'setblock @e[nbt={text:"ciao ,f=mondo"},type=Arrow,r=6] stone 6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);