re = /(?<name>\w+)=(?<value>.+?)(?=[,\]])(?#The following text makes sure that the match isn't inside quotes, #found_on_internet )(?=([^"\\]*(\\.|"([^"\\]*\\.)*[^"\\]*"))*[^"]*$)/
str = 'setblock @e[nbt={text:"ciao ,f=mondo"},type=Arrow,r=6] stone 6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end