package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<a[^>]*class=\s?['"]\s?whtbigheader\s?['"][^>]*>(.*?)</a>`)
var str = `<A HREF='/articles/0,7340,L-4664450,00.html' CLASS='whtbigheader' style='color:#FFFFFF;' HM=1>need to get this value</A>";
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}