$re = '/(\+7|8)(\(\d{3}\)|\d{3})\d{7}$/';
$str = '88121234567';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);