using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(30|2[1-9]|[01][1-9])\/([01][1-9]|1[0-2])\/(20[0-9][0-9]|19[7-9][0-9]|1970)$";
string input = @"111.111.111.111
251.5.5.7
00
01
05
20
25
248.255.0.5
127.0.1.0
132
127012
10.10.10.10
30
02/12/2000
00
01/01/19
30/12/2099
00
01
01
00
20
02
03
9
]87
09";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}