$re = '/^(30|2[1-9]|[01][1-9])\/([01][1-9]|1[0-2])\/(20[0-9][0-9]|19[7-9][0-9]|1970)$/m';
$str = '111.111.111.111
251.5.5.7
00
01
05
20
25
248.255.0.5
127.0.1.0
132
127012
10.10.10.10
30
02/12/2000
00
01/01/19
30/12/2099
00
01
01
00
20
02
03
9
]87
09';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);