#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)keyword_token:\s*(.*?)\s*(\d[a-zA-Z\d-]*)\(([^()]*)\)"
Local $sString = "# streetname 1() refers to house number 1 with an empty () additional qualifier " & @CRLF & _
"" & @CRLF & _
"keyword_token: street name 4()" & @CRLF & _
"keyword_token: street name 4a()" & @CRLF & _
"keyword_token: street name 4Aa()" & @CRLF & _
"keyword_token: street-name 14()" & @CRLF & _
"" & @CRLF & _
"keyword_token: streetname 123()keyword_token: streetname 123()" & @CRLF & _
"# why is it logged one message per line, but we get the address logged twice - sometimes??" & @CRLF & _
"" & @CRLF & _
"keyword_token: streetname 9(7)keyword_token: streetname 9(7)" & @CRLF & _
"keyword_token: streetname 27()\r\n a lot more text and log messages in the free form text log - one messageper line \n" & @CRLF & _
" " & @CRLF & _
"keyword_token: street-name 1-23(BLOCK D HAUS 6)keyword_token: street-name 1-23(BLOCK H HAUS 2)keyword_token: street-name 1-23(BLOCK G HAUS 3)'," & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"keyword_token: Streetname 96-98(13)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")