import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "keyword_token:\\s*(.*?)\\s*(\\d[a-zA-Z\\d-]*)\\(([^()]*)\\)";
final String string = "# streetname 1() refers to house number 1 with an empty () additional qualifier \n\n"
+ "keyword_token: street name 4()\n"
+ "keyword_token: street name 4a()\n"
+ "keyword_token: street name 4Aa()\n"
+ "keyword_token: street-name 14()\n\n"
+ "keyword_token: streetname 123()keyword_token: streetname 123()\n"
+ "# why is it logged one message per line, but we get the address logged twice - sometimes??\n\n"
+ "keyword_token: streetname 9(7)keyword_token: streetname 9(7)\n"
+ "keyword_token: streetname 27()\\r\\n a lot more text and log messages in the free form text log - one messageper line \\n\n"
+ " \n"
+ "keyword_token: street-name 1-23(BLOCK D HAUS 6)keyword_token: street-name 1-23(BLOCK H HAUS 2)keyword_token: street-name 1-23(BLOCK G HAUS 3)',\n"
+ " \n"
+ " \n"
+ "keyword_token: Streetname 96-98(13)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}