using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MyString (?!3\b)\d+";
string input = @"MyString 33
MyString 10
MyString 3
MyString 5";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}