$re = '/MyString (?!3\b)\d+/';
$str = 'MyString 33
MyString 10
MyString 3
MyString 5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);