re = /\$\{((?:(?:[A-z]+(?:\.[A-z0-9()\[\]\"]+)*)+|(?:\"[\w\/?.&=_\-]*\")+)+)}+$/m
str = '${test.one}${test.two}
${test.one}${test.two()}
${test.one}${"hello"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end