#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(.*),(.*)\)"
Local $sString = " [-0.2122,-0.1213)" & @CRLF & _
" [-0.2750,-0.2122)" & @CRLF & _
" [-0.1213,-0.0222)" & @CRLF & _
" [-0.1213,-0.0222)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")