re = /\[(.*),(.*)\)/m
str = ' [-0.2122,-0.1213)
[-0.2750,-0.2122)
[-0.1213,-0.0222)
[-0.1213,-0.0222)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end