$re = '/(Primary Page Category\s*=\s*(["\'])?((?:(?!\2).)*)\2?)/i';
$str = 'Primary Page Category = Template';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);