re = /(Primary Page Category\s*=\s*(["'])?((?:(?!\2).)*)\2?)/i
str = 'Primary Page Category = Template'
# Print the match result
str.match(re) do |match|
puts match.to_s
end