using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\([\bfs\b|\blang\b|\bri\b]*\d{2,4}|\s))";
string input = @"
\fs14 (font size 14)
\ri240 (right indent)
\lang1033 (applies a language to a character)
\lang1033
\
\
\hello !";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}