const regex = new RegExp('opt_((?:.*_)?(?!join$)[^\\r\\n_]+)$', 'gm')
const str = `opt_tw
opt_ls_join
opt_ac_join
opt_pan_join
opt_full_led`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}