import re
regex = re.compile(r"opt_((?:.*_)?(?!join$)[^\r\n_]+)$", flags=re.MULTILINE)
test_str = ("opt_tw\n"
"opt_ls_join\n"
"opt_ac_join\n"
"opt_pan_join\n"
"opt_full_led")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")